Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Archive des versions expérimentales 0.5 (+ 0.4.173 et 0.6.0.216 RC) qui ont précédé la sortie de la version 0.6.0, ainsi que des discussions qui les concernent.
Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 2054
Enregistré le : 05 août 2007, 12:57
Carte Tuner : August DVB-T210 USB + divers autres
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Gingko » 23 févr. 2009, 00:19

wizardcoder a écrit :Sur ma machine ça crash dés le départ, mais ma machine n'est pas une réf, j'ai installé DX10 et EVR sur un WinXp (Si si ça marche :wink: )

Message d'erreur: Impossible de connecté le codec vidéo au VMR
puis boîte de debug !
Quand ça commence à faire ça, il est fréquent qu'on ne s'en sorte pas sans redémarrer la machine.
(quoique parfois, changer de sortie VMR permette de contourner la chose temporairement)
wizardcoder a écrit : Aprés désinstalle + re-install : Plus de crashs au 1er démarrage, mais dés la fin du scan et qu'une chaîne s'affiche crash M6 (boîte de debug)
Au lancement suivant crash direct (boîte de debug) (avec ou sans paramétrage de ffdshow ffdshow tryouts rev 2527 Dec 17 2008 19:30:39 (msvc 2008, x86, unicode))...

Je t'ai mis des infos sur le SDK (2008 srv) dans mon thread HD... Il se peut que ça puisse t'aider un peu...

Bon courage c'est la phase la plus dure qui t'attend, avec coreavc fais gaffe je crois qu'il y a un anti debug, pour ffdshow en mode debug sa crash pas, mais moi j'ai une image noire... au moins on peu debugger...

A++
Étant donné que ça semble marcher chez au moins la moitié des autres expérimentateurs, j'aurais besoin de davantage d'informations pour comprendre le problème.

Éventuellement, essaie sur une autre configuration informatique ...

À noter que, bien que disposant de MSVC 2005 et de MSVC 2008, j'ai compilé cette version-là avec MSVC 2005. (j'avais pas envie pour le moment, en plus, de me prendre la tête avec des personnes qui n'auraient pas sur leur ordinateur les bibliothèques CRT correspondantes à MSVC 2008).

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : August DVB-T210, AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

fabien59
Messages : 135
Enregistré le : 06 mai 2007, 06:45
Carte Tuner : Nano Stick 73e , P7131 Dual

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par fabien59 » 23 févr. 2009, 00:33

marche impec sur Q6600 + 4 Go RAM sous windows xp avec ma P7131 . utilisation processeur 13 %

je vais tester avec ma nanostick 73e.

il faut impérativement que tu inséres l'E AC3 car à partir du 1er juin , les chaines tf1 france 2 m6 vont passer leur bande son en E-AC3, ca serait dommage de ne plus avoir de son.

pouvez vous insérer dans l'installation une option pour les chaines BELGES s'il vous plait ?


intégration des chaines belges pour ma part OK + logos OK.

j'ai toutes les informations ainsi que les logos à vous transmettre. prévenez moi si c'est possible.


Le Mod Expérimental me permet déjà de bénéficier de bénéficier des chaines HD en toute tranquilité !

merci !
Asus MyCinema P7131 Dual OK
2 x Pinnacle Nanostick 73e OK
PouchinTV Mod HD OK

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 2054
Enregistré le : 05 août 2007, 12:57
Carte Tuner : August DVB-T210 USB + divers autres
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Gingko » 23 févr. 2009, 06:41

alex_3d42 a écrit :
En attendant il est clair que les personnes qui n'arrivaient pas à utiliser l'AC3 en TNT normale ne pourront pas davantage l'utiliser en TNT HD.
Le problème sera résolu dans les prochaînes versions ?
Le problème est déjà que je n'ai pas de raison claire de présumer que ce soit Pouchin TV Mod qui est en cause, là.

Parce que le codec AC3 n'est pas fourni avec Pouchin TV Mod, c'est comme pour les autres codecs, chacun choisit celui qu'il veut, et PTVM ne fait qu'obéir.

Je ne peux pas tester pourquoi l'AC3 ne marche pas dans certaines configurations informatiques, parce que je ne dispose pas de configuration informatique dans laquelle l'AC3 ne marche pas.

Je pencherais plutôt pour un problème du côté de votre carte son, de son driver ou de sa configuration (normalement, l'AC3 est destiné à fonctionner avec 6 canaux, donc 6 haut-parleurs, après j'imagine qu'il est du ressort des fabricants des cartes son de décider ce qui se passe quand une carte son ne fournit pas autant de sorties).

Ou alors peut-être avez-vous simplement sélectionné un codec AC3 non valide ou qui ne fonctionne pas ?

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : August DVB-T210, AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 2054
Enregistré le : 05 août 2007, 12:57
Carte Tuner : August DVB-T210 USB + divers autres
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Gingko » 23 févr. 2009, 07:58

fabien59 a écrit :pouvez vous insérer dans l'installation une option pour les chaines BELGES s'il vous plait ?

intégration des chaines belges pour ma part OK + logos OK.

j'ai toutes les informations ainsi que les logos à vous transmettre. prévenez moi si c'est possible.
Bonjour,

D'accord, si vous pouviez me mettre tout ça dans un fichier .ZIP et me le transmettre en pièce jointe en message privé, ce serait sympa.

Au passage, puisqu'apparemment vous avez effectivement configuré PTVM pour les chaînes belges, pourriez-vous y inclure aussi une copie de votre fichier "chaines.xml" ? (dans le dossier %AppData%)

Merci d'avance,

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : August DVB-T210, AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

Maurice83300
Messages : 234
Enregistré le : 13 févr. 2009, 09:27
Carte Tuner : Hauppauge HVR4400, HVR900H

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Maurice83300 » 23 févr. 2009, 09:14

Bonjour,
P4 dual à 3,2 Ghz, 1GO RAM
XP-SP3
Carte graphique NVIDIA 6200 TM (Pas d'accélération H264).
Carte Hauppauge HVR 4000.

CODEC Cyberlink ne fonctionne pas.
CODEC Arcsoft ne fonctionne pas.

CODEC FFDShow fonctionne, mais ARTE pas très fluide:
- CPU globalement à un peu plus de 50%, mais le deuxième CPU reste uniforme à 100%, ce qui explique le manque de fluidité.
- Donc inutilisable avec ma carte VIDEO actuelle.
Depuis août 2010: W7-64 bits, Core-i3-530 2,93 GHz, 4 GO RAM, Radeon HD4350 512Mo, Hauppauge HVR 900H + HVR 4400 + Nova Duet, Ptvm 32bits V 0.6.3.352

alex_3d42
Messages : 30
Enregistré le : 16 sept. 2007, 16:45

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par alex_3d42 » 23 févr. 2009, 12:00

Le problème est déjà que je n'ai pas de raison claire de présumer que ce soit Pouchin TV Mod qui est en cause, là.

Parce que le codec AC3 n'est pas fourni avec Pouchin TV Mod, c'est comme pour les autres codecs, chacun choisit celui qu'il veut, et PTVM ne fait qu'obéir.

Je ne peux pas tester pourquoi l'AC3 ne marche pas dans certaines configurations informatiques, parce que je ne dispose pas de configuration informatique dans laquelle l'AC3 ne marche pas.

Je pencherais plutôt pour un problème du côté de votre carte son, de son driver ou de sa configuration (normalement, l'AC3 est destiné à fonctionner avec 6 canaux, donc 6 haut-parleurs, après j'imagine qu'il est du ressort des fabricants des cartes son de décider ce qui se passe quand une carte son ne fournit pas autant de sorties).

Ou alors peut-être avez-vous simplement sélectionné un codec AC3 non valide ou qui ne fonctionne pas ?

Gingko
Comme codec Ac3 j'ai essayé Ac3Filter 1.51a, Dscaler audio 0.0.8, Ffdshow audio (j'ai essayé la dernière version stable et la dernière version de compilation) et le filtre audio de mpc-hc en version 6.4.0.1. Tous sont bien configurés pour sortir du 5.1. Les paramètres de windows et de la carte son (soundblaster 7.1) sont bien réglés puisque j'ai du son dans les enceintes surrounds et centrale dans les autres applications.

Je vais essayer avec d'anciennes version de ptvm, j'essayerai aussi de reproduire ce bug dans Mpc-Hc et Vlc et je vous tient au courant.

Edit : J'ai essayer de reproduire le bug avec Mpc-hc, je post une capture d'écran pour vous montrer mes paramètres de codec et de sortie audio:
http://img13.imageshack.us/img13/5735/ptvm.jpg
Le son passe sur les 6 enceintes que dans les modes : System Default, Default DirectSound Device (00800000), DirectSound SB Live! 24-bits (00200000). Dans tous les autres modes de sortie il n'y a du son que sur les deux enceintes frontales.

Miguel
Messages : 26
Enregistré le : 01 déc. 2008, 19:39

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Miguel » 23 févr. 2009, 14:30

Je voudrai ajouter qu'avec cette version 0.4.173.0 ma clé Hauppauge Nova-T USB fonctionne enfin sous Pouchin TV, avant je n'avais qu'une seconde de son à chaque lancement, maintenant j'ai le son et l'image.

Cependant il y a encore quelques bugs :
- impossible de faire une recherche de chaînes, rien n'est trouvé, j'ai pourtant essayé divers offsets (0, -1, -166, -167).
- quand je passe d'une chaîne SD à une autre, l'image se fige et il n'y a plus de son, si je vais sur Arte HD, ça remarche, et si je retourne sur une autre chaîne SD, ça marche.
En gros, si je zappe d'une chaîne SD vers une autre SD, il ne se passe rien, je suis obligé de passer par Arte HD pour changer de chaîne.
J'ai essayé plusieurs codecs audio/vidéo et c'est toujours pareil.

Aussi, comme le signale jeams, j'ai une utilisation intensive du processeur par Pouchin TV sous Vista 64 en utilisant la version 32 bits, sur une chaîne SD je suis à 60% d'utilisation de mon C2D E8500 @ 3.8GHz, et si je mets Arte HD, ça monte à 80-90% d'utilisation CPU, mais ça reste très fluide, pas de ralentissement au niveau de l'image.

Edit modérateur (Gingko) : le paragraphe précédent réfère à des messages qui ne se trouvent plus dans le présent fil de discussion, car je les ai déplacés ici.


Par contre sur mon portable avec son tuner TNT AverMedia intégré, aucun problème de changement de chaîne ou d'utilisation processeur, il est sous Vista 32.

Sinon petite requète :
CoreAVC est sorti en version 1.9 dernièrement, il permet l'utilisation des cartes graphiques NVidia pour le décodage vidéo par CUDA si on a des pilotes plus récent que les 182.05.
Sur des films HD l'utilisation CPU passe de 50% à même pas 10% quand c'est ma carte graphique qui fait le boulot, mais dans Pouchin TV, l'icone de CoreAVC reste bleue, ce qui veut dire que le tout passe par le CPU, et non le GPU.
Pouchin TV fait appel à CoreAVC dès le départ alors qu'il n'y a pas encore de réception de flux, peut-être qu'à cause de ça CoreAVC ne détecte pas de bon format pris en charge par le décodeur CUDA et donc utilise seulement le CPU. Enfin je sais pas trop comment ça marche de ce côté là.

Avatar du membre
manureva45
Messages : 147
Enregistré le : 13 sept. 2007, 15:18

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par manureva45 » 23 févr. 2009, 19:00

Quelqu' un a-t-il essayé d' enregistrer une chaine HD , chez moi ça bug à mort et je n'ai que ARTE HD , on peut juste enregistrer en ts apparemment ... :(
Carte leadtek winfast dtv 1000 t
Emetteur : "la plaine du poteau" (orléans)
OS: Windows 7 GT pro 64, the best !

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 2054
Enregistré le : 05 août 2007, 12:57
Carte Tuner : August DVB-T210 USB + divers autres
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Gingko » 23 févr. 2009, 19:29

manureva45 a écrit :Quelqu' un a-t-il essayé d' enregistrer une chaine HD , chez moi ça bug à mort et je n'ai que ARTE HD , on peut juste enregistrer en ts apparemment ... :(
Pour enregistrer en TS il n'y avait rien à faire, alors que pour enregistrer en PS, il y a des transformations non négligeables à effectuer, alors je n'en ai pas fait une priorité.

Si l'enregistrement en TS pose des problèmes, essayez de le faire en mode minimisé, ça décharge considérablement le processeur.

Aussi, essayez d'augmenter la priorité du logiciel.

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : August DVB-T210, AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

fabien59
Messages : 135
Enregistré le : 06 mai 2007, 06:45
Carte Tuner : Nano Stick 73e , P7131 Dual

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par fabien59 » 23 févr. 2009, 20:03

l'enregistrement en .TS fonctionne à la perfection.
Asus MyCinema P7131 Dual OK
2 x Pinnacle Nanostick 73e OK
PouchinTV Mod HD OK

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 2054
Enregistré le : 05 août 2007, 12:57
Carte Tuner : August DVB-T210 USB + divers autres
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Gingko » 23 févr. 2009, 20:26

fabien59 a écrit :l'enregistrement en .TS fonctionne à la perfection.
J'imagine qu'il peut cependant poser des problèmes aux personnes qui sont en limite de capacité de leur processeur.

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : August DVB-T210, AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

fabien59
Messages : 135
Enregistré le : 06 mai 2007, 06:45
Carte Tuner : Nano Stick 73e , P7131 Dual

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par fabien59 » 23 févr. 2009, 20:29

oui c'est certain.

PS : tu as reçu mes messages privés ?
Asus MyCinema P7131 Dual OK
2 x Pinnacle Nanostick 73e OK
PouchinTV Mod HD OK

zati
Messages : 4
Enregistré le : 04 déc. 2007, 23:28

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par zati » 24 févr. 2009, 22:10

Bonjour,
J'ai testé cette version et ca marche plutôt pas mal
Je n'ai que Arte pour tester la HD.
En HD, avec FFDshow (Tryout Beta 6), des grosses saccades apparaissent et la conso CPU est aux alentours de 75%
Avec CoreAVC 1.9, c'est nickel. La conso CPU est tourne entre 45 et 55%
L'implantation du VMR9 est très appréciable.
Par contre, cocher la case "Utiliser l'AC3 par défaut" entraîne l'écriture de

Code : Tout sélectionner

Filtre AC3=[null] 
dans la config, ce qui fait immédiatement planter le soft.

Voilà, continuez comme ça !

Config de test : Core 2 Duo E6420, 4 go de ram, CM Gigabyte P35-DS3R, Carte TV Pinnacle PCTV Dual Hybrid pro PCIe, Vista 32 bits

Avatar du membre
Gingko
Administrateur du site et développeur
Messages : 2054
Enregistré le : 05 août 2007, 12:57
Carte Tuner : August DVB-T210 USB + divers autres
Êtes-vous un robot ? : Je ne suis pas un robot
Localisation : Pantin (IDF, 93)
Contact :

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par Gingko » 24 févr. 2009, 23:52

zati a écrit :Par contre, cocher la case "Utiliser l'AC3 par défaut" entraîne l'écriture de

Code : Tout sélectionner

Filtre AC3=[null] 
dans la config, ce qui fait immédiatement planter le soft.
Normalement, ce qui produit Filtre AC3=[null] dans le fichier de configuration, c'est le fait de sélectionner "Aucun" comme nom de codec (c'est valable pour tous les codecs, tant vidéo qu'audio, d'ailleurs).

Le fait de pouvoir mettre "Aucun" dans les codecs est une caractéristique que j'ai introduite en même temps, afin de pouvoir gérer le cas des utilisateurs qui ne disposeraient d'aucun codec pour un encodage donné d'une part, et aussi parce que j'ai rencontré quelquefois la situation de devoir impérativement désactiver un codec pour parvenir à accéder à la configuration des options, laquelle n'était pas accessible parce que le programme s'était placé dans le dialogue de configuration de première installation, situation impossible dont on ne pouvait auparavant se sortir qu'en allant détruire le fichier "config.ini" (ou en le modifiant à la main).

Le fait que ça plante avec un codec désactivé est un autre problème, qui tient surtout au fait que je me suis un peu précipité pour livrer cette version expérimentale, et que je n'avais pas implémenté partout le traitement correspondant à l'absence de codec, mais ce sera corrigé à la prochaine version. :)

Je n'ai pas identifié, pour le moment, de problème lié au fait de sélectionner l'option "Utiliser l'AC3 par défaut".

Gingko
Gingko
․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․ ․
Tuners utilisés, sur 3 ordis : • USB : August DVB-T210, AverMedia HDTV DVB-T Volar (2×) • PCI : Hauppauge Nova-DT Dual DVB-T • Express Card : AverMedia Digi Express 54

zati
Messages : 4
Enregistré le : 04 déc. 2007, 23:28

Re: Pouchin TV Mod 0.4.173.0 avec support HD expérimental

Message par zati » 25 févr. 2009, 08:44

Gingko a écrit :
zati a écrit :Par contre, cocher la case "Utiliser l'AC3 par défaut" entraîne l'écriture de

Code : Tout sélectionner

Filtre AC3=[null] 
dans la config, ce qui fait immédiatement planter le soft.
Normalement, ce qui produit Filtre AC3=[null] dans le fichier de configuration, c'est le fait de sélectionner "Aucun" comme nom de codec (c'est valable pour tous les codecs, tant vidéo qu'audio, d'ailleurs).
J'utilise AC3Filter. Est-ce que le fait qu'il apparaisse avant "aucun" dans la liste (qui a l'air triée par ordre alphabétique) pourrait expliquer le problème ? Si tu travailles avec l'index de la combobox et que tu considères que "aucun" est le 1er élément de la liste, ça pourrait expliquer mon souci.

Verrouillé